Nginx で WordPress REST API へのアクセス制限

この記事は2017年2月11日に公開したものです。情報が古い可能性がありますのでご注意ください。

久しぶりに WordPress に大きな脆弱性が公開されました。
WordPress 4.7 と 4.7.1 の REST API に認証を回避してコンテンツを書き換えられる脆弱性が存在します。攻撃は容易で、攻撃が成立するとコンテンツの書き換えが実行可能なため影響は大きいです。
続きを読む »

このエントリーをはてなブックマークに追加

WordPressの子テーマ作成

この記事は2017年1月15日に公開したものです。情報が古い可能性がありますのでご注意ください。

WordPressで既存のテーマをカスタマイズしたいことは多いと思いますが、その方法として子テーマの作成が推奨されてます。

例えばテーマに直接変更を加えていると、そのテーマのアップデート時にその変更が上書きされて消えてしまうので、それに影響されずにテーマをカスタマイズできたりと便利です。

続きを読む »

このエントリーをはてなブックマークに追加

WordPressの古い記事に対してメッセージを表示する

この記事は2016年12月3日に公開したものです。情報が古い可能性がありますのでご注意ください。

はじめに

少し前からブログなどで公開日が古い記事に対してその旨を示すメッセージが表示されているのを見る機会が多くなってきたような気がします。

IT技術系の記事などは変化の早い分野なのでそれに伴って情報の劣化も早く、その時点では正しくない情報の記事になってしまっていることもあります。そのような場合に閲覧者に注意を促したいと思い、WordPressでの古い記事に対してもメッセージを表示する方法を確認しましたので記載します。
プラグインやJavascriptなどで行う方法もあるようですが、ここではコードを追記する方法でやっています。

続きを読む »

このエントリーをはてなブックマークに追加

さくらのVPSのUbuntu 14.04へWordPress 4.4.1をインストール

この記事は2016年1月17日に公開したものです。情報が古い可能性がありますのでご注意ください。

はじめに

さくらのVPSのUbuntu 14.04にWordPress 4.4をインストールする手順です。

続きを読む »

このエントリーをはてなブックマークに追加